const regex = /(?<!\[)([a-z])(?!\1)([a-z])\2\1(?!])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\[)([a-z])(?!\\1)([a-z])\\2\\1(?!])', 'g')
const str = `baab[pqrs]asdf yes boobs
abcd[pqqp]xzzx no ..cc.
bbbb[zxcv]bnmkop no
adad ddss sdds ssssdds
ixooxj[kjhgfd]mnbvcxz yes
iubduyyr[exauibqlf]ytrddstz no
extoxp[bylubaahxfxiesk]brpqqpbo yes
[axxa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}