# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\[)([a-z])(?!\1)([a-z])\2\1(?!])"
test_str = ("baab[pqrs]asdf yes boobs\n"
"abcd[pqqp]xzzx no ..cc.\n"
"bbbb[zxcv]bnmkop no\n"
"adad ddss sdds ssssdds\n"
"ixooxj[kjhgfd]mnbvcxz yes\n"
"iubduyyr[exauibqlf]ytrddstz no\n"
"extoxp[bylubaahxfxiesk]brpqqpbo yes\n\n"
"[axxa\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.