import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\[)([a-z])(?!\\1)([a-z])\\2\\1(?!])";
final String string = "baab[pqrs]asdf yes boobs\n"
+ "abcd[pqqp]xzzx no ..cc.\n"
+ "bbbb[zxcv]bnmkop no\n"
+ "adad ddss sdds ssssdds\n"
+ "ixooxj[kjhgfd]mnbvcxz yes\n"
+ "iubduyyr[exauibqlf]ytrddstz no\n"
+ "extoxp[bylubaahxfxiesk]brpqqpbo yes\n\n"
+ "[axxa\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}