const regex = /\([^-]+-(.+\.(png|jpg))\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^-]+-(.+\\.(png|jpg))\\)', 'gm')
const str = `(background_apartment_450-533c-d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.png)
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg)
background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}