import Foundation
let pattern = #"\([^-]+-(.+\.(png|jpg))\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(background_apartment_450-533c-d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.png)
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg)
background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5.jpg
(background_apartment_450-533c0d6072a192f2846a6d076a0d21cbae40c4901d476676ff0e24611ce199d5)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)