#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Date Tripped:\s*([:A-Za-z0-9\s]+)\r?\n"
Local $sString = "Name: Full Report" & @CRLF & _
"Store: River North (Wells St)" & @CRLF & _
"Date Tripped: 18 Feb 2020 8:40 PM" & @CRLF & _
"Business Date: 18 Feb 2020 (Closed)" & @CRLF & _
"Message:" & @CRLF & _
"Information:" & @CRLF & _
"This alert was tripped based on a user defined trigger: Every 5 minutes."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")