# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Date Tripped:\s*([:A-Za-z0-9\s]+)\r?\n"
test_str = ("Name: Full Report\n"
"Store: River North (Wells St)\n"
"Date Tripped: 18 Feb 2020 8:40 PM\n"
"Business Date: 18 Feb 2020 (Closed)\n"
"Message:\n"
"Information:\n"
"This alert was tripped based on a user defined trigger: Every 5 minutes.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.