import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Date Tripped:\\s*([:A-Za-z0-9\\s]+)\\r?\\n";
final String string = "Name: Full Report\n"
+ "Store: River North (Wells St)\n"
+ "Date Tripped: 18 Feb 2020 8:40 PM\n"
+ "Business Date: 18 Feb 2020 (Closed)\n"
+ "Message:\n"
+ "Information:\n"
+ "This alert was tripped based on a user defined trigger: Every 5 minutes.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}