using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Date Tripped:\s*([:A-Za-z0-9\s]+)\r?\n";
string input = @"Name: Full Report
Store: River North (Wells St)
Date Tripped: 18 Feb 2020 8:40 PM
Business Date: 18 Feb 2020 (Closed)
Message:
Information:
This alert was tripped based on a user defined trigger: Every 5 minutes.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}