package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\[([^\[\]]+)`)
var str = `3[a]2[bc]
3[a2[c]]
2[abc]3[cd]ef
abc3[cd]xyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}