import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?! )(?!.* $)[\\w *()\\[\\]'\"\\/.&–-]+$";
final String string = " abcd 123\n"
+ "abcdfds(fdsa454Abcv)[das]12345 fdaAAFBVD'\"/.-_&–fds fdsa\n"
+ "abc 123 \n"
+ "foo-bar_123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}