$re = '/^(?! )(?!.* $)[\w *()\[\]\'"\/.&–-]+$/m';
$str = ' abcd 123
abcdfds(fdsa454Abcv)[das]12345 fdaAAFBVD\'"/.-_&–fds fdsa
abc 123
foo-bar_123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);