const regex = /^(?! )(?!.* $)[\w *()\[\]'"\/.&–-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?! )(?!.* $)[\\w *()\\[\\]\'"\\\/.&–-]+$', 'gm')
const str = ` abcd 123
abcdfds(fdsa454Abcv)[das]12345 fdaAAFBVD'"/.-_&–fds fdsa
abc 123
foo-bar_123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}