re = /^(?! )(?!.* $)[\w *()\[\]'"\/.&–-]+$/m
str = ' abcd 123
abcdfds(fdsa454Abcv)[das]12345 fdaAAFBVD\'"/.-_&–fds fdsa
abc 123
foo-bar_123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end