#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(-)(.*)(-)(.*)"
Local $sString = "2015-09-11" & @CRLF & _
"2015-09-11" & @CRLF & _
"2015-09-11" & @CRLF & _
"2015-09-11" & @CRLF & _
"2015-09-11" & @CRLF & _
"2015-09-11" & @CRLF & _
"2015-09-11" & @CRLF & _
"2015-10-11" & @CRLF & _
"2015-10-11" & @CRLF & _
"2015-10-11" & @CRLF & _
"2015-10-11" & @CRLF & _
"2015-10-11" & @CRLF & _
"2015-10-11" & @CRLF & _
"2015-11-11" & @CRLF & _
"2015-12-11" & @CRLF & _
"2015-12-11" & @CRLF & _
""
Local $sSubst = "\1\2\5\4\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)