import Foundation
let pattern = #"(.*)(-)(.*)(-)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-11-11
2015-12-11
2015-12-11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\5\4\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)