package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(-)(.*)(-)(.*)`)
var str = `2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-11-11
2015-12-11
2015-12-11
`
var substitution = "\1\2\5\4\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}