import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(-)(.*)(-)(.*)";
final String string = "2015-09-11\n"
+ "2015-09-11\n"
+ "2015-09-11\n"
+ "2015-09-11\n"
+ "2015-09-11\n"
+ "2015-09-11\n"
+ "2015-09-11\n"
+ "2015-10-11\n"
+ "2015-10-11\n"
+ "2015-10-11\n"
+ "2015-10-11\n"
+ "2015-10-11\n"
+ "2015-10-11\n"
+ "2015-11-11\n"
+ "2015-12-11\n"
+ "2015-12-11\n";
final String subst = "\\1\\2\\5\\4\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}