import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^p(11[45][234])\\.bla\\.com";
final String string = "p80.bla.com\n"
+ "p443.bla.com\n"
+ "p1142.bla.com\n"
+ "p1143.bla.com\n"
+ "p1144.bla.com\n"
+ "p1145.bla.com\n"
+ "p1154.bla.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}