$re = '/^p(11[45][234])\.bla\.com/m';
$str = 'p80.bla.com
p443.bla.com
p1142.bla.com
p1143.bla.com
p1144.bla.com
p1145.bla.com
p1154.bla.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);