import re
regex = re.compile(r"^p(11[45][234])\.bla\.com", flags=re.MULTILINE)
test_str = ("p80.bla.com\n"
"p443.bla.com\n"
"p1142.bla.com\n"
"p1143.bla.com\n"
"p1144.bla.com\n"
"p1145.bla.com\n"
"p1154.bla.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")