// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^p(11[45][234])\.bla\.com").unwrap();
let string = "p80.bla.com
p443.bla.com
p1142.bla.com
p1143.bla.com
p1144.bla.com
p1145.bla.com
p1154.bla.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}