#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?sm)^([^,]+?),.+?(?:(\n(?!\1))|\Z)"
Local $sString = "Christi,19946752,20194048" & @CRLF & _
"Christi,20369664,20520192" & @CRLF & _
"Christi,20520192,20631296" & @CRLF & _
"Christi,20123984,20124432" & @CRLF & _
"Brandon,20194048,20369664" & @CRLF & _
"Brandon,20745984,20980736" & @CRLF & _
"Brandon,22341211,22443280" & @CRLF & _
"Joe-010,28729383,28733432" & @CRLF & _
"Joe-010,23488449,23499482"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")