use strict;
my $str = 'Christi,19946752,20194048
Christi,20369664,20520192
Christi,20520192,20631296
Christi,20123984,20124432
Brandon,20194048,20369664
Brandon,20745984,20980736
Brandon,22341211,22443280
Joe-010,28729383,28733432
Joe-010,23488449,23499482';
my $regex = qr/(?sm)^([^,]+?),.+?(?:(\n(?!\1))|\Z)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}