# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?sm)^([^,]+?),.+?(?:(\n(?!\1))|\Z)"
test_str = ("Christi,19946752,20194048\n"
"Christi,20369664,20520192\n"
"Christi,20520192,20631296\n"
"Christi,20123984,20124432\n"
"Brandon,20194048,20369664\n"
"Brandon,20745984,20980736\n"
"Brandon,22341211,22443280\n"
"Joe-010,28729383,28733432\n"
"Joe-010,23488449,23499482")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.