package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^member_`)
var str = `member_abc123
member_I_am_a_member
not_a_member
never_been_invited_let_alone_an_m_word
member_some_random_group`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}