// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^member_").unwrap();
let string = "member_abc123
member_I_am_a_member
not_a_member
never_been_invited_let_alone_an_m_word
member_some_random_group";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}