$re = '/^member_/m';
$str = 'member_abc123
member_I_am_a_member
not_a_member
never_been_invited_let_alone_an_m_word
member_some_random_group';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);