package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+$`)
var str = `https://www.obi.at/aussenleuchten/aussen-stehleuchten-wegeleuchten/schwarz/f/123456789
https://www.obi.at/987654321
Hausbooot192837465`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}