$re = '/\d+$/m';
$str = 'https://www.obi.at/aussenleuchten/aussen-stehleuchten-wegeleuchten/schwarz/f/123456789
https://www.obi.at/987654321
Hausbooot192837465';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);