re = /\d+$/m
str = 'https://www.obi.at/aussenleuchten/aussen-stehleuchten-wegeleuchten/schwarz/f/123456789
https://www.obi.at/987654321
Hausbooot192837465'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end