import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "function(.|\\n)*\\{(.|\\n)*if(.|\\n)*function ";
final String string = " onRenderComplete: function () {\n"
+ " pageData.orderingAll = viewModel.tabAllGrid.getOrdering();\n\n"
+ " if (app.session.features.openNotesAndMessagesFromList_VEA14870) {\n"
+ " $('#tabAllGrid .connectedMessageIcon').on('click', function (e) {\n\n"
+ " var $messages = $(e.target),\n"
+ " $row = $messages.parents('.gridRow'),\n"
+ " rowId = $row.data('row'),\n"
+ " rowData = $('#tabAllGrid').vismaGrid('getRowData', rowId);\n"
+ " postItMessageModal(rowData);\n"
+ " });\n\n"
+ " function postItMessageModal(data) {\n"
+ " var documentType = null;\n"
+ " var documentId = null;\n"
+ " var urls = data.invoiceUrl.split('/');\n"
+ " if (urls.length > 3 && urls[3]) {\n"
+ " documentType = urls[2];\n"
+ " var guidRegex = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/;\n"
+ " if (urls[3].match(guidRegex)) {\n"
+ " documentId = urls[3];\n"
+ " } else {\n"
+ " documentId = urls[4];\n"
+ " }\n"
+ " }\n"
+ " app.shell.viewModel.commentViewModel.getMessagesForGivenDocument(documentType, documentId, false, true);\n"
+ " };\n"
+ " }\n"
+ " },\n"
+ " initialSelected: initialSelectedAll\n"
+ " };";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}