import re
regex = re.compile(r"function(.|\n)*{(.|\n)*if(.|\n)*function ", flags=re.MULTILINE)
test_str = (" onRenderComplete: function () {\n"
" pageData.orderingAll = viewModel.tabAllGrid.getOrdering();\n\n"
" if (app.session.features.openNotesAndMessagesFromList_VEA14870) {\n"
" $('#tabAllGrid .connectedMessageIcon').on('click', function (e) {\n\n"
" var $messages = $(e.target),\n"
" $row = $messages.parents('.gridRow'),\n"
" rowId = $row.data('row'),\n"
" rowData = $('#tabAllGrid').vismaGrid('getRowData', rowId);\n"
" postItMessageModal(rowData);\n"
" });\n\n"
" function postItMessageModal(data) {\n"
" var documentType = null;\n"
" var documentId = null;\n"
" var urls = data.invoiceUrl.split('/');\n"
" if (urls.length > 3 && urls[3]) {\n"
" documentType = urls[2];\n"
" var guidRegex = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/;\n"
" if (urls[3].match(guidRegex)) {\n"
" documentId = urls[3];\n"
" } else {\n"
" documentId = urls[4];\n"
" }\n"
" }\n"
" app.shell.viewModel.commentViewModel.getMessagesForGivenDocument(documentType, documentId, false, true);\n"
" };\n"
" }\n"
" },\n"
" initialSelected: initialSelectedAll\n"
" };")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")