// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)function(.|\n)*{(.|\n)*if(.|\n)*function ").unwrap();
let string = " onRenderComplete: function () {
pageData.orderingAll = viewModel.tabAllGrid.getOrdering();
if (app.session.features.openNotesAndMessagesFromList_VEA14870) {
$('#tabAllGrid .connectedMessageIcon').on('click', function (e) {
var $messages = $(e.target),
$row = $messages.parents('.gridRow'),
rowId = $row.data('row'),
rowData = $('#tabAllGrid').vismaGrid('getRowData', rowId);
postItMessageModal(rowData);
});
function postItMessageModal(data) {
var documentType = null;
var documentId = null;
var urls = data.invoiceUrl.split('/');
if (urls.length > 3 && urls[3]) {
documentType = urls[2];
var guidRegex = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/;
if (urls[3].match(guidRegex)) {
documentId = urls[3];
} else {
documentId = urls[4];
}
}
app.shell.viewModel.commentViewModel.getMessagesForGivenDocument(documentType, documentId, false, true);
};
}
},
initialSelected: initialSelectedAll
};";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}