const regex = /function(.|\n)*{(.|\n)*if(.|\n)*function /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function(.|\\n)*{(.|\\n)*if(.|\\n)*function ', 'gm')
const str = ` onRenderComplete: function () {
pageData.orderingAll = viewModel.tabAllGrid.getOrdering();
if (app.session.features.openNotesAndMessagesFromList_VEA14870) {
\$('#tabAllGrid .connectedMessageIcon').on('click', function (e) {
var \$messages = \$(e.target),
\$row = \$messages.parents('.gridRow'),
rowId = \$row.data('row'),
rowData = \$('#tabAllGrid').vismaGrid('getRowData', rowId);
postItMessageModal(rowData);
});
function postItMessageModal(data) {
var documentType = null;
var documentId = null;
var urls = data.invoiceUrl.split('/');
if (urls.length > 3 && urls[3]) {
documentType = urls[2];
var guidRegex = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?\$/;
if (urls[3].match(guidRegex)) {
documentId = urls[3];
} else {
documentId = urls[4];
}
}
app.shell.viewModel.commentViewModel.getMessagesForGivenDocument(documentType, documentId, false, true);
};
}
},
initialSelected: initialSelectedAll
};`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}