import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(\\[)(\\d+\\.\\d+\\.\\d+)(,)(\\s)(\\d+:\\d+:\\d+)(])(\\s)([^:]+)(:)(.*?)(?=\\[\\d+\\.\\d+\\.\\d+,\\s\\d+:\\d+:\\d+]|\\Z)";
final String string = " [12.06.17, 13:18:36] Name1: Test test test\n"
+ " [12.06.17, 13:20:20] Name2 ❤️: blabla\n"
+ " [12.06.17, 13:20:44] Name2 ❤️: words words words\n"
+ " words\n"
+ " words\n"
+ " words\n"
+ " [12.06.17, 13:29:03] Name1: more words more words\n"
+ " [12.06.17, 13:38:52] Name3 Surname Nickname: 👍🏼\n"
+ " [12.06.17, 13:40:37] Name1: message?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}