import re
regex = re.compile(r"(?s)(\[)(\d+\.\d+\.\d+)(,)(\s)(\d+:\d+:\d+)(])(\s)([^:]+)(:)(.*?)(?=\[\d+\.\d+\.\d+,\s\d+:\d+:\d+]|\Z)", flags=re.MULTILINE)
test_str = (" [12.06.17, 13:18:36] Name1: Test test test\n"
" [12.06.17, 13:20:20] Name2 ❤️: blabla\n"
" [12.06.17, 13:20:44] Name2 ❤️: words words words\n"
" words\n"
" words\n"
" words\n"
" [12.06.17, 13:29:03] Name1: more words more words\n"
" [12.06.17, 13:38:52] Name3 Surname Nickname: 👍🏼\n"
" [12.06.17, 13:40:37] Name1: message?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")