const regex = new RegExp('(?s)(\\[)(\\d+\\.\\d+\\.\\d+)(,)(\\s)(\\d+:\\d+:\\d+)(])(\\s)([^:]+)(:)(.*?)(?=\\[\\d+\\.\\d+\\.\\d+,\\s\\d+:\\d+:\\d+]|\\Z)', 'gm')
const str = ` [12.06.17, 13:18:36] Name1: Test test test
[12.06.17, 13:20:20] Name2 ❤️: blabla
[12.06.17, 13:20:44] Name2 ❤️: words words words
words
words
words
[12.06.17, 13:29:03] Name1: more words more words
[12.06.17, 13:38:52] Name3 Surname Nickname: 👍🏼
[12.06.17, 13:40:37] Name1: message?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}