package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*[^a-zA-Z\s]`)
var str = `Hedgehog's shoes
The Fox Machine
The Armadillo\`s wish`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}