re = /.*[^a-zA-Z\s]/
str = 'Hedgehog\'s shoes
The Fox Machine
The Armadillo`s wish'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end