$re = '/.*[^a-zA-Z\s]/';
$str = 'Hedgehog\'s shoes
The Fox Machine
The Armadillo`s wish';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);