# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\\/([A-Za-z0-9]{24})(?:\\/.*)?$/$1/gim;t' <<< "/v1/api2/5eb98050122d484001708a11f
/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/"