package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im).*\/([A-Za-z0-9]{24})(?:\/.*)?$`)
var str = `/v1/api2/5eb98050122d484001708a11f
/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}