using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/([A-Za-z0-9]{24})(?:\/.*)?$";
string substitution = @"$1";
string input = @"/v1/api2/5eb98050122d484001708a11f
/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}