#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\bfoo\((?=[^()]*\))|\G(?!^))[^']*(?:'\h*[,:]\h*)?'\K\w+"
Local $sString = "foo('Alice') -> Expected Hits: Alice" & @CRLF & _
"foo('Alice', 'Bob', 'Charlie') -> Expected Hits: Alice, Bob, Charlie" & @CRLF & _
"foo(flag ? 'Alice' : 'Bob') -> Expected Hits: Alice, Bob"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")