using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\bfoo\((?=[^()]*\))|\G(?!^))[^']*(?:'\h*[,:]\h*)?'\K\w+";
string input = @"foo('Alice') -> Expected Hits: Alice
foo('Alice', 'Bob', 'Charlie') -> Expected Hits: Alice, Bob, Charlie
foo(flag ? 'Alice' : 'Bob') -> Expected Hits: Alice, Bob";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}