re = /(?:\bfoo\((?=[^()]*\))|\G(?!^))[^']*(?:'\h*[,:]\h*)?'\K\w+/m
str = 'foo(\'Alice\') -> Expected Hits: Alice
foo(\'Alice\', \'Bob\', \'Charlie\') -> Expected Hits: Alice, Bob, Charlie
foo(flag ? \'Alice\' : \'Bob\') -> Expected Hits: Alice, Bob'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end