#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([\d\s]*)\((\d{3})\)"
Local $sString = "1 (555)555-5555"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)