package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\d\s]*)\((\d{3})\)`)
var str = `1 (555)555-5555`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}