const regex = /^([\d\s]*)\((\d{3})\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\d\\s]*)\\((\\d{3})\\)', 'g')
const str = `1 (555)555-5555`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);